إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

تحديث linux mint debian

تقليص
X
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [مشكلة] تحديث linux mint debian

    السلام عليكم و رحمة الله

    قمت بتحميل اخر نسخه لنظام linux mint debian و قمت بتركيبه بالكامل :::

    و السؤال هو ,,

    عند عمل تقسيم للقرص الصلب هل يجب عمل قسم swap ??? لانني عملته باكمله ext4 .

    عند عمل تحديث للنظام و تباع الخطوات كما في الرابط ادناه

    http://blog.linuxmint.com/?p=1836

    عند عمل install للبرامج يظهر لي خيار لا اذكره تماما ,, و لكنه عن auto maintaner كما اذكر و يخيرني بين yes and defult

    و انا اخترت yes !

    من خلال التريمينال ,,, و التحديث حجمه تقريبا 350 ميغابايت .

    عند اتمام الخطوات الى الان ارى نفس التحديث و هو Update Pack 3

    مع انني قمت بالتحديث سابقا !!!

    و الان عند محاولة التحديث مرة اخرى يظهر لي An error occurred

    E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1

    و لا يمكنني التحديث !!

    لا اعلم هل لانني ضغطت yes ام ماذا !!

    مع العلم انني قمت بتغيير المخازن كما هو موضح في الشرح في الرابط الاول ,,

    افيدوني جزاكم الله خيرا لانني على وشك ازالة النظام و محاولة تثبيته مرة اخرى .

    النسخة عندي 32 بت .

    و شكرا
    التعديل الأخير تم بواسطة aloooi; الساعة 21-10-2011, 03:51 PM.

  • #2
    هنا حل المشكلة

    http://forums.linuxmint.com/viewtopic.php?f=198&t=83724

    الحل هو
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
    مع الاستبدال الى

    gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
    [email protected]_linux ~ $ sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
    [sudo] password for ali:
    (Reading database ... 138333 files and directories currently installed.)
    Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
    Unpacking replacement gstreamer0.10-plugins-bad ...
    dpkg: warning: overriding problem because --force enabled:
    trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
    Setting up gstreamer0.10-plugins-bad (0.10.22-3) ...
    Processing triggers for libglib2.0-0 ...
    ساقوم بطرح موضوع كامل عن كيفية التحديث ان شاء الله

    تعليق


    • #3
      هل تم الحل

      تم حل المشكلة ﻷنها نفس ما حدث معي ..
      لكن هل هذه التوزيعة تعتمد على نواة معالج واحدة مع العلم أن توزيعة منت المبنية على اوبنتو كانت تقرأ المعالج بنواتان ؟و هل ينبغي علي تنثبيت إصدارة 64 بت للإستفادة من كامل قدرات الجهاز ؟
      التعديل الأخير تم بواسطة m.shazly; الساعة 08-11-2011, 02:07 PM.

      تعليق


      • #4
        السلام عليكم أسمح لي اخي الكريم ان أضع لك حلا نابعا من تجربتي الشخصية أرجو ان يفيدك

        بالنسبة للتحديث بعد تغير المخازن كما ذكر يتم التحديث بطرقة عادية ، وصولا غلى الملف المذكور تظهر رسالة الخطا ، عن نفسي قمت بإزالة التأشير عن الملف محاولة التحديث تم بنجاح ثم البحث عن التحديثات فيظهر الملف السالف الذكر وحيد ا ، طلبت منه التحديث فتم بنجاح

        بالنسبة لتفعيل اﻷنوية فعن نفسي كذلك بعد البحث في المنتديات قمت بتركيب كرنل اسمه : liquorix
        بتباع الرشادات من الرابط / http://liquorix.net
        قم باضافة المستودع ثم التوجه إلى ٍsynaptic
        و تثبيت الكرنل تجده قد تعرف على بقية أنوية المعالج ، الكرنل لا أدري مدى توافقيته أو مشاكله مع النظام فعذرا موفق بإذن الله
        سبحانك اللهم و بحمدك أشهد ألا إله إلا أنت أستغفرك و أتوب إليك
        الرجاء الدعاء لشخص أجنبي بالهداية للإسلام بارك الله فيكم.

        تعليق

        يعمل...
        X