إعـــــــلان

تقليص
لا يوجد إعلان حتى الآن.

الإصدار الجديد من برنامج كروان - Curlew

تقليص
X
  • تصفية - فلترة
  • الوقت
  • عرض
إلغاء تحديد الكل
مشاركات جديدة

  • [جديد] الإصدار الجديد من برنامج كروان - Curlew

    بسم الله الرحمن الرحيم

    السلام عليكم ورحمة الله

    يسعدني أقدم لكم اليوم النسخة الجديدة من برنامج تحويل الوسائط كروان Curlew الذي يحمل الإصدار 0.2.0 والتي أرجو أن تنال إعجابكم .
    حيث أدخلت عليه العديد من التحسينات وصححت العديد من الأخطاء مع إضافة بعض الميزات.

    لمن يرغب في مشاهدة الموضوع السابق للبرنامج من هنا.

    من بين الميزات والتحسينات ما يلي:

    - إعادة تصميم وتحسين للواجهة.
    - إمكانية تحرير الصيغ وحفظها.
    - إمكانية تحديد قارئ فضلا عن القارئ الافتراضي.
    - تحسين مصغرات الفيديو.
    - إضافة نافذة لإظهار الكوديك المتوفرة بالنسبة للمحول.
    - الإشعار بعدم توفر كوديك معين قبل عملية التحويل.
    - تحسين جميع مربعات الحوار.
    - وتحسينات أخرى….

    للتحميل من هنا
    نسخة ديبان من هنا


    بعض لقطات الشاشة من بيئة سطح المكتب جنوم.

    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-1.png 
مشاهدات:	1 
الحجم:	40.7 كيلوبايت 
الهوية:	855418
    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-2.png 
مشاهدات:	1 
الحجم:	36.4 كيلوبايت 
الهوية:	855419
    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-3.png 
مشاهدات:	1 
الحجم:	44.9 كيلوبايت 
الهوية:	855420
    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-4.png 
مشاهدات:	1 
الحجم:	94.8 كيلوبايت 
الهوية:	855421
    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-5.png 
مشاهدات:	1 
الحجم:	50.7 كيلوبايت 
الهوية:	855422
    اضغط على الصورة لعرض أكبر. 

الإسم:	curlew-6.png 
مشاهدات:	1 
الحجم:	64.4 كيلوبايت 
الهوية:	855423


    تقبلوا تحياتي، وفي انتظار تصويباتكم واقتراحاتكم.
    التعديل الأخير تم بواسطة فيصل شامخ; الساعة 26-02-2016, 08:04 PM.

  • #2
    وعليكم السلام و رحمة الله وبركاتة
    جزاك الله خير، كنا بالإنتظار بفارغ الصبر

    ملاحظتى هي، عند تحميل حزمة deb ومحاولة تثبيتها (mint 17.3) طلب من تثبيت python3.5
    قمت بتثبيتها ثم طلب مني gir1.2-gtk-3.0_3.12.2
    قمت بتحميلها لتثبيتها طلب مني libgtk3-0

    في الإصدار السابق لم يكن يحدث هذا الأمر!
    قد يكون تتبع الإعتمادات وتثبيتها مضجر قليلاً (وقد يكون صعب على مبتدئ)
    لاحظة فى بعض حزم deb عندما يكون هناك نقص بالأعتماديات يقوم بجلها تلقائيًا وتثبيتها ثم تثبيت البرنامج

    وجزاك الله خير الجزاء ورحم والديك (سأعو إن شاء الله بعد الإنتهاء من الأعتماديات ^_^)

    تعليق


    • #3
      ملاحظتى هي، عند تحميل حزمة deb ومحاولة تثبيتها (mint 17.3) طلب من تثبيت python3.5
      قمت بتثبيتها ثم طلب مني gir1.2-gtk-3.0_3.12.2
      قمت بتحميلها لتثبيتها طلب مني libgtk3-0
      أعمل على أبنتو 15.10 واجهة جنوم وجربت الحزمة ولم تطلب إلى تثبيت الاعتماديات (ffmpeg/libav-utils و libavcodec-extra)
      من المفروض أن منت مبنية على مكتبات Gtk ولا يتطلب الأمر تثبيتها مجددا.

      في السابق واجهتني مشكلة مع منت، إذ أن حزمة libavcodec-extra تثبيتها يقوم بحذف حزم مهمة من التوزيعة.


      في الإصدار السابق لم يكن يحدث هذا الأمر!
      قد يكون تتبع الإعتمادات وتثبيتها مضجر قليلاً (وقد يكون صعب على مبتدئ)
      لاحظة فى بعض حزم deb عندما يكون هناك نقص بالأعتماديات يقوم بجلها تلقائيًا وتثبيتها ثم تثبيت البرنامج
      لم يتغير شيء سوى تحديث إصدار الاعتماديات مثلا مكتبة Gtk من 3.10 إلى 3.12
      كذلك التنصيب يتم بشكل تلقائي إذا كانت توزيعتك تحتوي على إصدار Gtk أكبر أو يساوي 3.12

      تعليق


      • #4
        كود:
        [email protected]:~$ curlew %U sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. No module named 'dbus'
        تحذير + مشكلة

        يحتاج الى حزمة python3-dbus ارجو اضافتها الى الإعتمادية
        اللهم انى أسألك العفو و العافية
        قال رسول الله (من كان يؤمن بالله واليوم الأخر فليقل خيراً أو ليصمت): فهل أنت تقول الخير ؟

        تعليق


        • #5
          المشاركة الأصلية بواسطة عبدالحميد بينو مشاهدة المشاركة
          كود:
          [email protected]:~$ curlew %U sys:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. No module named 'dbus'
          تحذير + مشكلة

          يحتاج الى حزمة python3-dbus ارجو اضافتها الى الإعتمادية
          تم التحديث، بارك الله فيك أخي عبد الحميد.
          مع أن التحذير لا يظهر لدي (Gtk 3.16) هل تستعمل إصدارة أعلى؟.

          للتحميل.

          تعليق


          • #6
            جميل ما شاء الله , تحسينات أكثر من رائعة !
            بارك الله فيك وجعله في موازين حسناتك .

            بمناسبة أنك تعمل على GTK+ هل جربت Glade لإنشاء الوجهات ؟ القي نظرة عليه .
            مستخدم GNU Linux, GNOME
            GTK+ :: C, C++, Pascal, Vala, Rust
            GIMP, Inkscape
            GitHub : 0x3UH4224D
            IRC : muhannad :: Tiwtter : @MuhannadRusayni

            تعليق


            • #7
              المشاركة الأصلية بواسطة مهند الرسيني مشاهدة المشاركة
              جميل ما شاء الله , تحسينات أكثر من رائعة !
              بارك الله فيك وجعله في موازين حسناتك .

              بمناسبة أنك تعمل على GTK+ هل جربت Glade لإنشاء الوجهات ؟ القي نظرة عليه .
              وفيك بارك الله.
              بالنسبة لبرنامج Glade فقد جربته سابقا، لكن بداية كتابة البرنامج كانت بدونه لهذا لم أرد أن أعيد تصميم الواجهة.

              تعليق


              • #8
                هذه من عندي Ubuntu gnome 15.10 مع اني عندي حزم كثيرة مثبتة:
                كود:
                $ sudo dpkg -i Downloads/curlew_0.2.0-1_all.deb 
                [sudo] password for user: 
                Selecting previously unselected package curlew.
                (Reading database ... 674322 files and directories currently installed.)
                Preparing to unpack .../curlew_0.2.0-1_all.deb ...
                Unpacking curlew (0.2.0-1) ...
                dpkg: dependency problems prevent configuration of curlew:
                 curlew depends on python3.5; however:
                  Package python3.5 is not installed.
                 curlew depends on mediainfo; however:
                  Package mediainfo is not installed.
                
                dpkg: error processing package curlew (--install):
                 dependency problems - leaving unconfigured
                Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
                Processing triggers for gnome-menus (3.13.3-6ubuntu1) ...
                Processing triggers for desktop-file-utils (0.22-1ubuntu3) ...
                Processing triggers for mime-support (3.58ubuntu1) ...
                Errors were encountered while processing:
                 curlew
                لم أجرب بعد التحديث لأني ثبت تلك الحزم
                https://twitter.com/damas_ua، للمحادثة المباشرة تجدني باسم az في قناة المجتمع

                تعليق


                • #9
                  curlew depends on python3.5; however:
                  Package python3.5 is not installed.
                  curlew depends on mediainfo; however:
                  Package mediainfo is not installed.
                  على ما يبدو من رسالة الخطأ عليك تنصيب mediainfo و python3.5


                  لماذا لا تجرب gdebi من سطر الأوامر لحل جميع الاعتماديات بشكل تلقائي
                  كود:
                  sudo gdebi curlew_0.2.0-1_all.deb

                  تعليق


                  • #10
                    ذكرت أني ثبت الحزمتين استاذي وحللت المشكلة.

                    بالمناسبة سبق أن ذكرك الأخوة في قناة المجتمع ونصحوا أحد الشباب باستخدام برنامجك. نشكرك على هذا الجهد وان شاء الله يكون في المستودعات الرسمية قريبا.

                    عندما حاولت تحويل فيديو إلى 3gp ظهر لي أنه حصل خطأ وعند رؤية التفاصيل كانت النص فارغ:

                    كود:
                    Command line #1:
                    ****************
                    ffmpeg -y -i /home/user/vokoscreen-2016-01-31_11-46-24.mkv -f 3gp -b:v 80k -r 15 -vcodec h263 -aspect 16:9 -vf scale=128:96 -b:a 4750 -ar 8000 -ac 1 -acodec libopencore_amrnb /home/user/vokoscreen-2016-01-31_11-46-24.3gp
                    
                    Error detail:
                    *************
                    لا شيء تحت Error detail:


                    وعندي مقترحين بخصوص التصميم إذا سمحت لي، عندما تختار الترميز فإن زر قبول التغيير جميل لكنه صغير جدا لو تجعله أطول حتى يبدو أنه زر اساسي ولسهولة الاستخدام.


                    كذلك رمز التحويل مغمور بين الرموز الأخرى. أقترح أيضا أن يكون زر التحويل أطول مما حوله فهو الأهم والأكثر استخداما
                    https://twitter.com/damas_ua، للمحادثة المباشرة تجدني باسم az في قناة المجتمع

                    تعليق


                    • #11
                      ذكرت أني ثبت الحزمتين استاذي وحللت المشكلة.
                      الحمد لله مع أنني نصبت الحزمة ولم يطلب مني تثبيت الإصدار 3.5 من بايثون.

                      عندما حاولت تحويل فيديو إلى 3gp ظهر لي أنه حصل خطأ وعند رؤية التفاصيل كانت النص فارغ:
                      أجل، يحدث أحيانا أن البرنامج لا يعرض تفاصيل الخطأ إلا بعد محاولة أو اثنتين.
                      إذهب إلى التبويب Audio، قد تجد عبارة "libopencore_amrnb Codec not found" أمام Audio Codec أي أن الترميز libopencore_amrnb غير موجود
                      دائما ما استعمل المحول ffmpeg النسخة static build لتجنب تنصيب مثل الحزمة libavcodec-extra
                      أو جرب نسخ سطر الأمر ونفذه في الطرفية وترى تفاصيل الخطأ.


                      ....
                      بالنسبة لاقتراح التصميم سأحاول أن أجد حلا مناسبا

                      وشكرا لك على الاهتمام.

                      تحديث: يمكن الضغط مرتين على الصيغة لاختيارها
                      التعديل الأخير تم بواسطة فيصل شامخ; الساعة 27-02-2016, 05:39 PM.

                      تعليق


                      • #12
                        أرجوا سحب التحديثات إلى موقعك على
                        https://github.com/chamfay/Curlew

                        تعليق


                        • #13
                          المشاركة الأصلية بواسطة jalal_haj مشاهدة المشاركة
                          أرجوا سحب التحديثات إلى موقعك على
                          https://github.com/chamfay/Curlew
                          ربما لن أستخدم نظام الـ github على الأقل في الوقت الحالي.

                          تعليق


                          • #14
                            مع أن التحذير لا يظهر لدي (Gtk 3.16) هل تستعمل إصدارة أعلى؟.
                            نعم 3.18.7 ديبيان sid
                            لا يوجد مشاكل في الواجهة . لقد قمت بمعاينة العديد من الإحتمالات .
                            الرابط الى رخصة وقف غير موجودة http://ojuba.org/www/wiki/doku.php/waqf/license )
                            اللهم انى أسألك العفو و العافية
                            قال رسول الله (من كان يؤمن بالله واليوم الأخر فليقل خيراً أو ليصمت): فهل أنت تقول الخير ؟

                            تعليق


                            • #15
                              المشاركة الأصلية بواسطة فيصل شامخ مشاهدة المشاركة
                              ربما لن أستخدم نظام الـ github على الأقل في الوقت الحالي.
                              أرجو أن تعمل على ذلك بأقرب قرصة .
                              (لَا تَحْسَبَنَّ الَّذِينَ يَفْرَحُونَ بِمَا أَتَوا وَّيُحِبُّونَ أَن يُحْمَدُوا بِمَا لَمْ يَفْعَلُوا فَلَا تَحْسَبَنَّهُم بِمَفَازَةٍ مِّنَ الْعَذَابِ وَلَهُمْ عَذَابٌ أَلِيمٌ)
                              آل عمران 188
                              قال رسول الله صلى الله عليه و سلم :
                              {لا يشكر الله من لا يشكر الناس}
                              {من كان يؤمن بالله واليوم الآخر،فليقل خيراً أو ليصمت}

                              جميع المساهمات الحاملة لهذا التوقيع تخضع لرخصة وقف
                              أسأل الله العظيم رب العرش العظيم أن يحسن من حال أمتي

                              تعليق

                              يعمل...
                              X